iThemes Security Pro v6.8.0 [Latest Version]

 

iThemes Security Pro is one of the best security plugins for WordPress users. It helps you fix common WordPress security issues and adds an extra layer of security to save your site from hackers. iThemes Security also has a free version available, but it comes with minimal security features. If you need premium features like two-factor authentication, version management, and many others, then you should go for the Pro version of this plugin. iThemes Security Pro is easy to use and user-friendly plugin, even a beginner can set up this in a few minutes. This plugin also offers automated malware protection. When the malware scan feature is enabled, it will automatically scan your site for malware every day. If it found any malware on your website, an email will be automatically sent to your mail address.

Features of iThemes Security Pro WordPress Plugin

  • Removes WordPress Security Breaches
  • Brute Force Protection for WordPress
  • Automatically detects any file change in your database
  • Force you to create a strong password
  • Bans Multiple failed login attempts IP.
  • Makes WordPress Dashboard inaccessible during specific hours
  • Scheduled database backup
  • Change the default WordPress login URL
  • Notification through mail address if anything goes wrong
  • Two-factor authentication
  • Security dashboard to monitor activities
  • Bans specific IP and user agents
  • Automated Malware Protection
  • Trusted devices
  • Automatic software updates
  • Allow changing content directory
  • Database table prefix change also possible

What’s New in iThemes Security Pro v6.8.0 (Changelog)

  • New Feature: iThemes Security now supports Passwordless Login and reCAPTCHA v3 for Restrict Content Pro ( version 6.4.3 and later ).
  • Enhancement: Overwrite Restrict Content Pro’s detected IP address with the IP detected by iThemes Security.
  • Tweak: Application Passwords compatibility with WordPress 5.6.
  • Bug Fix: Two Factor and Passwords Requirements compatibility with Restrict Content Pro.
  • Bug Fix: PHP warnings that may occur when initializing default user groups on a new installation.
  • Important: iThemes Security requires WordPress 5.4 or later.
  • New Feature: Manage bans from the Security Dashboard with the new Banned Users card.
  • Enhancement: Support writing a note describing why a ban was added.
  • Enhancement: Add a WP CLI command for managing bans, wp itsec ban.
  • Bug Fix: PHP warnings when invalid entries are stored in the WordPress Cron storage.
  • And some other minor improvements and bug fixes.

Recommend : Shield Security Pro v9.2.1

SALE PAGE

iThemes Security Pro v6.8.0

We will be happy to hear your thoughts

Leave a reply

Register New Account
Reset Password
Compare items
  • Total (0)
Compare